About Gallery SF.net Project Bug tracker Downloads Forums Manual Wiki DevBlog News

Python3 support comes to Vegastrike

In preparation for what will ultimately become 0.6, after many hours and an angry girlfriend or two, we give you python3 functional vegastrike along with updating boost to 1.53.0 (in-tree).

Get vegastrike’s repo at

https://vegastrike.svn.sourceforge.net/svnroot/vegastrike/branches/py3/vegastrike

and the data dir at

https://vegastrike.svn.sourceforge.net/svnroot/vegastrike/branches/py3/data

You need python3 to run this and the default option for system boost is reversed from normal trunk.   So disable the option if your in-system version of libboost_python is not up to 0.5x.y and doesn’t have a python3 target.

Right now we need as many people building and working off of the branch as possible to iron out any remaining bugs and issues.   It seems to be much less forgiving of code errors so that should help track down problems and get things even more stable than in the 0.5.x release.

NOTE:

It should work with your current savegame data, the python files will be re-compiled automatically.

This has only been tested on unix.  The Win32 side of things needs to update their build files to point to 0.53.0 for in-tree boost.   Though, that’s all they’d have to do.  There are no changes in defines needed or differences in filenames (added or removed) from the old 0.45 version of boost that was in the repo.

 MODS:

Those mods out there wishing to port to python3 need to first process their files with 2to3 and an indent cleaner.  Then go through and any non-loop uses of “range” need to be wrapped in list() to get the same functionality..  Also, they need to go through all their uses of division and ensure any int/int divisions are handled with // to keep the same behavior.  There aren’t many other issues that VS comes across other than that…. but little things may turn up so the porting process is a handle-as-needed thing.    Keep in mind, the current rev  13522 is identical in functionality to the 0.5.1r1 release but updated to handle python3 and boost 1.53.0 so any mods working with that but just want to run for the foreseeable future without needing users to downgrade libs can use this.  0.6 will contain many other changes that will certainly break 0.5.x mods .   

Leave a Reply

You must be logged in to post a comment.